【原创】解决React Native报错:错误: 方法不会覆盖或实现超类型的方法

blogdaren 2018-08-05 抢沙发 866人次

问题背景

编译报错:/path/to/UpgradePackage.java:26: 错误: 方法不会覆盖或实现超类型的方法

> Task :app:compileDebugJavaWithJavac
/path/to/UpgradePackage.java:26: 错误: 方法不会覆盖或实现超类型的方法
    @Override
    ^
1 个错误

问题原因

重写父类中的抽象方法时,不允许添加注解:@Override

解决方案

删除注解: @Override


版权声明:除非注明,本文由( blogdaren )原创,转载请保留文章出处。

本文链接:【原创】解决React Native报错:错误: 方法不会覆盖或实现超类型的方法

发表评论:

您的昵称:
电子邮件:
个人主页: