【原创】解决composer报错:Composer/Packagist could not find package for minimum stability

blogdaren 2018-11-21 抢沙发 98人次

问题背景:

执行 composer require blogdaren/custom-terminal-color , 结果报错:


  [InvalidArgumentException]                                                                                                                       
  Could not find a version of package blogdaren/custom-terminal-color matching your minimum-stability (stable). Require it with an explicit version constraint allowing its desired stability.  

问题原因:

这是因为没有发布release包造成。

解决方案-1:

composer require blogdaren/custom-terminal-color:dev-master

解决方案-2:

点击 https://github.com/blogdaren/CustomTerminalColor/releases, 发布 release 包,然后执行:

composer require blogdaren/custom-terminal-color 

版权声明:除非注明,本文由( blogdaren )原创,转载请保留文章出处。

本文链接:【原创】解决composer报错:Composer/Packagist could not find package for minimum stability

发表评论:

您的昵称:
电子邮件:
个人主页: