【原创】解决composer报错:Your requirements could not be resolved to an installable set of packages......but these conflict with your requirements or minimum-stability

blogdaren 2018-11-24 抢沙发 83人次

问题背景:

执行命令: composer require blogdare/logger 报错:

Using version ^1.0 for blogdaren/logger
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Installation request for blogdaren/logger ^1.0 -> satisfiable by blogdaren/logger[v1.0.0].
    - blogdaren/logger v1.0.0 requires blogdaren/custom-terminal-color dev-master -> satisfiable by blogdaren/custom-terminal-color[dev-master] but these conflict with your requirements or minimum-stability.

问题原因:

待补充......

解决方案:

在项目根目录下的 composer.json 文件中新增如下一条指令:

 "minimum-stability": "dev"

发表评论:

您的昵称:
电子邮件:
个人主页: