【原创】解决rabbitmq报错:configure: error: Please reinstall the librabbitmq distribution itself or (re)install librabbitmq development package if it available in your system

blogdaren 2019-03-27 抢沙发 408人次

问题背景:

编译安装rabbitmq扩展,结果报错:

configure: error: Please reinstall the librabbitmq distribution itself or (re)install librabbitmq development package if it available in your system

问题原因:

这是因为没有安装 AMQP 的依赖包 rabbitmq-c 所致

解决方案:

编译安装 AMQP 的依赖包 rabbitmq-c

编译安装 rabbitmq-c 依赖包:

# wget https://github.com/alanxz/rabbitmq-c/releases/download/v0.8.0/rabbitmq-c-0.8.0.tar.gz
# tar zxf rabbitmq-c-0.8.0.tar.gz
# cd rabbitmq-c-0.8.0
# ./configure --prefix=/usr/local/rabbitmq-c
# make && make install

编译安装 rabbitmq 扩展:

 # ./configure --with-php-config=/path/to/php-config --with-amqp --with-librabbitmq-dir=/usr/local/rabbitmq-c/
 # make && make install

#rabbitmq#

发表评论:

您的昵称:
电子邮件:
个人主页: